<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

			<style type="text/css">
				.slide-excerpt { width: 100%; }
				.slide-excerpt { top: 0; }
				.slide-excerpt { left: 0; }
				.flexslider { max-width: 1440px; max-height: 400px; }
				.slide-image { max-height: 400px; }
			</style>
	<!-- This site is optimized with the Yoast SEO plugin v14.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Man Gouges Out Neighbor’s Eyes Over A Noisy Rooster</title>
	<meta name="description" content="A man in West Virginia is blamed for gouging out the eyes of his neighbor and slaying him after an argument over a deafening rooster, police said." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Man Gouges Out Neighbor’s Eyes Over A Noisy Rooster" />
	<meta property="og:description" content="A man in West Virginia is blamed for gouging out the eyes of his neighbor and slaying him after an argument over a deafening rooster, police said." />
	<meta property="og:url" content="http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/" />
	<meta property="og:site_name" content="Social News Daily" />
	<meta property="article:publisher" content="http://facebook.com/socialnewsdaily" />
	<meta property="article:author" content="facebook.com/mahlg" />
	<meta property="article:published_time" content="2020-05-20T00:20:09+00:00" />
	<meta property="article:modified_time" content="2020-05-20T07:43:48+00:00" />
	<meta property="og:image" content="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Webp.net-resizeimage-2020-05-19T201611.978.jpg" />
	<meta property="og:image:width" content="640" />
	<meta property="og:image:height" content="400" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.socialnewsdaily.com/#website","url":"https://www.socialnewsdaily.com/","name":"Social News Daily","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.socialnewsdaily.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/#primaryimage","inLanguage":"en-US","url":"https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Webp.net-resizeimage-2020-05-19T201611.978.jpg","width":640,"height":400,"caption":"rooster"},{"@type":"WebPage","@id":"http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/#webpage","url":"http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/","name":"Man Gouges Out Neighbor\u2019s Eyes Over A Noisy Rooster","isPartOf":{"@id":"https://www.socialnewsdaily.com/#website"},"primaryImageOfPage":{"@id":"http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/#primaryimage"},"datePublished":"2020-05-20T00:20:09+00:00","dateModified":"2020-05-20T07:43:48+00:00","author":{"@id":"https://www.socialnewsdaily.com/#/schema/person/cd01fa6a98f6fa2fcabcdc22c7d54140"},"description":"A man in West Virginia is blamed for gouging out the eyes of his neighbor and slaying him after an argument over a deafening rooster, police said.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/"]}]},{"@type":["Person"],"@id":"https://www.socialnewsdaily.com/#/schema/person/cd01fa6a98f6fa2fcabcdc22c7d54140","name":"Aaron Granger","image":{"@type":"ImageObject","@id":"https://www.socialnewsdaily.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d3a9093b8b45af6f031b603605b1e11f?s=96&d=mm&r=g","caption":"Aaron Granger"},"sameAs":["facebook.com/mahlg","linkedin.com/in/aarongrangerrules"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Social News Daily &raquo; Feed" href="https://www.socialnewsdaily.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Social News Daily &raquo; Comments Feed" href="https://www.socialnewsdaily.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Social News Daily &raquo; Man Gouges Out Neighbor’s Eyes Over A Noisy Rooster Comments Feed" href="https://www.socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.socialnewsdaily.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='news-pro-css'  href='https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/style.css?ver=3.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.socialnewsdaily.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://www.socialnewsdaily.com/wp-content/plugins/wp-logo-showcase-responsive-slider-slider/assets/css/slick.css?ver=2.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='logo_showcase_style-css'  href='https://www.socialnewsdaily.com/wp-content/plugins/wp-logo-showcase-responsive-slider-slider/assets/css/logo-showcase.css?ver=2.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.socialnewsdaily.com/wp-includes/css/dashicons.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.socialnewsdaily.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.5' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='https://www.socialnewsdaily.com/wp-content/plugins/genesis-responsive-slider/assets/style.css?ver=1.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.socialnewsdaily.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.socialnewsdaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.socialnewsdaily.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://wp.me/p2HbDg-noW' />
<link rel="alternate" type="application/json+oembed" href="https://www.socialnewsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.socialnewsdaily.com%2F89958%2Fman-gouges-out-neighbors-eyes-over-a-noisy-rooster%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.socialnewsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.socialnewsdaily.com%2F89958%2Fman-gouges-out-neighbors-eyes-over-a-noisy-rooster%2F&#038;format=xml" />

<!-- Twitter Cards Meta - V 2.5.4 -->
<meta name="twitter:card" content="photo" />
<meta name="twitter:site" content="@socialnewsdaily" />
<meta name="twitter:creator" content="@socialnewsdaily" />
<meta name="twitter:url" content="https://www.socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/" />
<meta name="twitter:title" content="Man Gouges Out Neighbor’s Eyes Over A Noisy Rooster" />
<meta name="twitter:description" content="A man in West Virginia is blamed for gouging out the eyes of his neighbor and slaying him after an argument over a deafening rooster, police said." />
<meta name="twitter:image" content="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Webp.net-resizeimage-2020-05-19T201611.978.jpg" />
<!-- Twitter Cards Meta By WPDeveloper.net -->


<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/images/SocialNewsDaily-icon.png" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-41565402-5"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41565402-5');
</script>
</head>
<body class="post-template-default single single-post postid-89958 single-format-standard desktop content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-container-wrap"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.socialnewsdaily.com" title="Social News Daily"><img src="https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/images/SocialNewsDaily.png" alt="Social News Daily" class="site-logo"></a></p></div><div class="widget-area header-widget-area"><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><a class="social" href="https://www.facebook.com/SocialNewsDaily"><span class="dashicons dashicons-facebook-alt"></span></a> 
<a class="social" href="https://twitter.com/socialnewsdaily"><span class="dashicons dashicons-twitter"></span></a> 
<a class="social" href="https://socialnewsdaily.com/feed/"><span class="dashicons dashicons-rss"></span></a></div></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-header-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-47160" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-47160"><a href="https://www.socialnewsdaily.com/social-media/" itemprop="url"><span itemprop="name">Social Media</span></a></li>
<li id="menu-item-47161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47161"><a href="https://www.socialnewsdaily.com/entertainment/social-celebs/" itemprop="url"><span itemprop="name">Social Celebs</span></a></li>
<li id="menu-item-47162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47162"><a href="https://www.socialnewsdaily.com/shareables/social-video/" itemprop="url"><span itemprop="name">Social Video</span></a></li>
<li id="menu-item-47163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47163"><a href="https://www.socialnewsdaily.com/hoaxed/" itemprop="url"><span itemprop="name">Hoaxed</span></a></li>
<li id="menu-item-47164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47164"><a href="https://www.socialnewsdaily.com/entertainment/" itemprop="url"><span itemprop="name">Entertainment</span></a></li>
<li id="menu-item-67903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67903"><a href="https://www.socialnewsdaily.com/politics/" itemprop="url"><span itemprop="name">Politics</span></a></li>
<li id="menu-item-47165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47165"><a href="#" itemprop="url"><span itemprop="name">More!</span></a>
<ul class="sub-menu">
	<li id="menu-item-47305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47305"><a href="https://www.socialnewsdaily.com/entertainment/social-humor/" itemprop="url"><span itemprop="name">Social Humor</span></a></li>
	<li id="menu-item-47307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47307"><a href="https://www.socialnewsdaily.com/enterprise/social-business/" itemprop="url"><span itemprop="name">Social Business</span></a></li>
	<li id="menu-item-47308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47308"><a href="https://www.socialnewsdaily.com/entertainment/social-music/" itemprop="url"><span itemprop="name">Social Music</span></a></li>
	<li id="menu-item-47310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47310"><a href="https://www.socialnewsdaily.com/entertainment/social-sports/" itemprop="url"><span itemprop="name">Social Sports</span></a></li>
	<li id="menu-item-47168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47168"><a href="https://www.socialnewsdaily.com/shareables/social-photos/" itemprop="url"><span itemprop="name">Social Photos</span></a></li>
	<li id="menu-item-47309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47309"><a href="https://www.socialnewsdaily.com/social-gaming/" itemprop="url"><span itemprop="name">Social Gaming</span></a></li>
	<li id="menu-item-47306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47306"><a href="https://www.socialnewsdaily.com/social-law/" itemprop="url"><span itemprop="name">Social Law</span></a></li>
	<li id="menu-item-47167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47167"><a href="https://www.socialnewsdaily.com/mobile/" itemprop="url"><span itemprop="name">Mobile</span></a></li>
	<li id="menu-item-60150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60150"><a href="https://www.socialnewsdaily.com/meet-our-team/" itemprop="url"><span itemprop="name">Meet Our Team</span></a></li>
</ul>
</li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-89958 post type-post status-publish format-standard has-post-thumbnail category-matrix category-social-media tag-animals entry" itemscope itemtype="https://schema.org/CreativeWork">			<div class="entry-category">Social Media</div>
			<header class="entry-header"><h1 class="entry-title" itemprop="headline">Man Gouges Out Neighbor’s Eyes Over A Noisy Rooster</h1>
<p class="entry-meta">Published on <time class="entry-time" itemprop="datePublished" datetime="2020-05-19T20:20:09-04:00">May 19, 2020</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.socialnewsdaily.com/author/aaron-granger/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Aaron Granger</span></a></span> </p></header><img width="640" height="400" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Webp.net-resizeimage-2020-05-19T201611.978.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="rooster" /><div id="before-entry" class="before-entry"><div class="flexible-widgets widget-area  widget-full"><div class="wrap"><section id="execphp-2" class="widget widget_execphp"><div class="widget-wrap"><h3 class="widgettitle widget-title">Share This Article</h3>
			<div class="execphpwidget"><div class="shareit"> 
  <a class="link link-fb" href="https://www.facebook.com/sharer/sharer.php?u=https://www.socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/" target="_blank"> 
    <span class="dashicons dashicons-facebook-alt"></span>
  </a> 
  <a class="link link-tw" href="https://twitter.com/share?text=BMan Gouges Out Neighbor’s Eyes Over A Noisy Rooster&amp;related=splashpress" target="_blank"> 
    <span class="dashicons dashicons-twitter"></span>
  </a> 
  <a class="link link-gp" href="https://plus.google.com/share?url=https://www.socialnewsdaily.com/89958/man-gouges-out-neighbors-eyes-over-a-noisy-rooster/" target="_blank"> 
    <span class="dashicons dashicons-googleplus"></span>
    </a>
</div></div>
		</div></section>
</div></div></div><div class="entry-content" itemprop="text"><p>A man in West Virginia is blamed for gouging out the eyes of his neighbor and slaying him after an argument over a deafening rooster, police said.</p>
<p>According to the Mercer County Sheriff’s Office, 47-year-old Richard Wayne Ellison of <a href="https://en.wikipedia.org/wiki/Rock,_West_Virginia" target="_blank" rel="noopener noreferrer">Rock</a>, WV was charged with second-degree murder in link with the murder of Benny Foutch. Ellison informed a detective he slaughtered the rooster because it was crowing too vociferously, and then gouged Foutch’s eyes out simply because “Satan made him do it.” The Princeton Rescue Squad had been phoned to the house on an unconnected complaint and discovered Foutch’s body outside his home on the porch.</p>
<p><span id="more-89958"></span></p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">Investigator: Argument over a rooster led to slaying, victim&#39;s eyes were gouged out<a href="https://t.co/2m1v2B6ATm">https://t.co/2m1v2B6ATm</a></p>
<p>&mdash; Blfd Daily Telegraph (@BDTonline) <a href="https://twitter.com/BDTonline/status/1262495343591202816?ref_src=twsrc%5Etfw">May 18, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>“Blood was coming out of his orbital sockets,” authorities wrote. Detective-Corporal M.S. Horn explained that while snapping photos around Foutch’s frame, he detected “a large number of feathers, which appeared to be from a chicken,” says the criminal complaint. Ellison’s son stated his dad had brought a deceased rooster back to his property. When Ellison was asked about Foutch, an investigator noted Ellison performed “a hand motion of pressing his thumbs to his eyes.”</p>
<p>Horn expressed in the complaint: “He advised he went up there to kill the rooster because of a movie he had watched and because it was crowing. He later explained that he pressed his thumbs into Benny’s eyes, he advised that he stayed there until he knew Benny was dead. He made the statement that he killed him, referring to the incident with Benny. He made a reference that Lucifer made him do it. He kept asking me to shoot him, that he deserved it. He then talked about getting somebody in the jail to kill him.” Via a videoconference, Ellison was arraigned and his bail was set at $200,000.</p>
<p>YOU MAY LIKE:</p>
<p><a href="https://socialnewsdaily.com/88458/wolf-woman-bites-neighbors-ear-off/" target="_blank" rel="noopener noreferrer">Woman Believing She’s A Wolf Bites ‘Vampire’ Neighbor’s Ear Off</a></p>
<p><a href="https://socialnewsdaily.com/84685/man-threw-mannequin-fiesta/" target="_blank" rel="noopener noreferrer">Man Gets Revenge On Neighbor With Kinky Mannequin “Party” (Pics)</a></p>
</div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='https://secure.gravatar.com/avatar/d3a9093b8b45af6f031b603605b1e11f?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d3a9093b8b45af6f031b603605b1e11f?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Aaron Granger</span></h4><div class="author-box-content" itemprop="description"></div></section></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://www.socialnewsdaily.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-5ec59db82b9463.27640495" placeholder="Search this website &#x2026;"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://www.socialnewsdaily.com/?s={s}"></form></div></section>
<section id="featured-post-5" class="widget featured-content featuredpost"><div class="widget-wrap"><article class="post-89970 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics category-social-tips tag-coronavirus tag-coronavirus-usa tag-covid-19 entry"><a href="https://www.socialnewsdaily.com/89970/the-symptoms-of-a-covid-19-denier/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="600" height="400" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/corona-4970836_640.jpg" class="entry-image attachment-post" alt="https://pixabay.com/photos/corona-coronavirus-mask-protection-4970836/" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89970/the-symptoms-of-a-covid-19-denier/">The Symptoms of a COVID-19 Denier</a></h4></header><div class="entry-content"><p>Despite concrete data and research, people’s opinions will always be diverse when it comes to a variety of topics including religion, politics, gender, and more. Denial is a common reaction to many important discussions and serious world events. The COVID-19 pandemic does not differ from any issues and is subject to opinions from critiques all&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89970/the-symptoms-of-a-covid-19-denier/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article><article class="post-89943 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics tag-covid-19 tag-japan entry"><a href="https://www.socialnewsdaily.com/89943/how-japans-pm-abe-handled-the-coronavirus-outbreak-differently-from-other-countries/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="648" height="400" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/PM-Abe.jpg" class="entry-image attachment-post" alt="" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89943/how-japans-pm-abe-handled-the-coronavirus-outbreak-differently-from-other-countries/">How Japan&#8217;s PM Abe Handled the Coronavirus Outbreak Differently From Other Countries</a></h4></header><div class="entry-content"><p>Back in January, when the Wuhan, China coronavirus broke out, it didn’t make it to the front page of newspapers, in print or virtual form. Today, January feels like a lifetime away. Like it or not, people around the world have adapted to the new normal &#8211; staying at home, frequent hand washing, and social&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89943/how-japans-pm-abe-handled-the-coronavirus-outbreak-differently-from-other-countries/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article><article class="post-89911 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics tag-covid-19 tag-donald-trump tag-politicians tag-rodrigo-duterte entry"><a href="https://www.socialnewsdaily.com/89911/the-worst-politicians-to-handle-a-pandemic/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="600" height="400" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Rodrigo_Duterte_delivers_his_message_to_the_Filipino_community_in_Vietnam_during_a_meeting_held_at_the_Intercontinental_Hotel_on_September_28.jpg" class="entry-image attachment-post" alt="worst politicians covid" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89911/the-worst-politicians-to-handle-a-pandemic/">The Worst Politicians to Handle a Pandemic</a></h4></header><div class="entry-content"><p>Since the beginning of the year 2020, the whole world has been stupefied by the rapid spread of a deadly coronavirus known as COVID-19. World superpowers in the West were unable to prevent the virus from reaching their borders. Because of this fact, the novel coronavirus COVID-19 became a world-wide pandemic no less than three&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89911/the-worst-politicians-to-handle-a-pandemic/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article><article class="post-89883 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics tag-covid-19 tag-politics tag-science entry"><a href="https://www.socialnewsdaily.com/89883/walking-and-cycling-a-new-normal-of-transit-after-the-covid-19/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="604" height="400" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/05/Pedestrians.jpg" class="entry-image attachment-post" alt="" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89883/walking-and-cycling-a-new-normal-of-transit-after-the-covid-19/">Walking and Cycling: A ‘New Normal’ of Transit after the COVID-19</a></h4></header><div class="entry-content"><p>For months since the start of 2020, the attention of the world has focused on immediate response efforts to contain and combat the novel coronavirus, also known as COVID-19. The deadly virus has pushed millions of people into isolation.  This kept people in their homes for weeks and months away from their work, their friends,&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89883/walking-and-cycling-a-new-normal-of-transit-after-the-covid-19/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article><article class="post-89792 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics tag-steven-mnuchin entry"><a href="https://www.socialnewsdaily.com/89792/treasury-wants-stimulus-payments-to-deceased-people-repaid/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="660" height="372" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/04/f088dc97-09d7-443c-a74b-5571030c8ae2-VPC_MONEY_STIM_CHECKS_PROBS_WIDE_GETTY.jpg" class="entry-image attachment-post" alt="treasury" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89792/treasury-wants-stimulus-payments-to-deceased-people-repaid/">Treasury Wants Stimulus Payments to Deceased People Repaid</a></h4></header><div class="entry-content"><p>According to the Treasury Department, economic stimulus payments erroneously sent to dead people ought to be returned. A Treasury spokesperson revealed the department is formulating a plan to recover the COVID-19 related payments but didn&#8217;t furnish details. Steven Mnuchin, Treasury Secretary, stated “heirs should be returning that money,” in an interview on Wednesday. He explained&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89792/treasury-wants-stimulus-payments-to-deceased-people-repaid/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article><article class="post-89620 post type-post status-publish format-standard has-post-thumbnail category-matrix category-politics tag-coronavirus entry"><a href="https://www.socialnewsdaily.com/89620/countries-beginning-to-crackdown-on-human-freedoms/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="640" height="360" src="https://www.socialnewsdaily.com/wp-content/uploads/2020/04/coronavirus_world.jpg" class="entry-image attachment-post" alt="countries" itemprop="image" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://www.socialnewsdaily.com/89620/countries-beginning-to-crackdown-on-human-freedoms/">Countries and Their Crackdown Against Freedoms and Democracy</a></h4></header><div class="entry-content"><p>Countries around the world are utilizing the coronavirus as a guise to clamp down on human rights for political motivations. Though some constraints are undoubtedly imperative to address an outbreak, there is an authentic risk that this crisis could ignite a lasting worldwide backslide in foundational freedoms — and it’s already begun. While an epidemic&hellip;<a class="more-link" href="https://www.socialnewsdaily.com/89620/countries-beginning-to-crackdown-on-human-freedoms/">Continue Reading&nbsp;&rsaquo;</a></p>
</div></article></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p><a href="https://www.socialnewsdaily.com"><img src="https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/images/SocialNewsDaily-icon.png" alt="Social News Daily" width="100" class="site-icon"></a></p><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-menu" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-47176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47176"><a href="https://www.socialnewsdaily.com/?page_id=16987" itemprop="url"><span itemprop="name">Write For Us</span></a></li>
<li id="menu-item-47177" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47177"><a href="https://www.socialnewsdaily.com/meet-our-team/" itemprop="url"><span itemprop="name">Meet Our Team</span></a></li>
<li id="menu-item-47174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47174"><a href="https://www.socialnewsdaily.com/snd-services/" itemprop="url"><span itemprop="name">SND Services</span></a></li>
<li id="menu-item-47175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47175"><a href="https://www.socialnewsdaily.com/social-news/" itemprop="url"><span itemprop="name">Social News</span></a></li>
<li id="menu-item-47172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47172"><a href="https://www.socialnewsdaily.com/copyright-policy/" itemprop="url"><span itemprop="name">Copyright Policy</span></a></li>
<li id="menu-item-47173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47173"><a href="https://www.socialnewsdaily.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li id="menu-item-84095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84095"><a href="https://www.socialnewsdaily.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
</ul></div></nav></div></footer></div></div>	<div style="display:none">
	<div class="grofile-hash-map-d3a9093b8b45af6f031b603605b1e11f">
	</div>
	</div>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: 0,controlNav: 1,animationDuration: 800,slideshowSpeed: 6000    });  });</script><script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202021'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.5'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/js/jquery.matchHeight.min.js?ver=3.2.3'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/js/global.js?ver=3.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-primary",".nav-header"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/themes/snd-news-pro-latest/js/responsive-menus.min.js?ver=3.2.3'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/plugins/genesis-responsive-slider/assets/js/jquery.flexslider.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9'></script>
<script type='text/javascript' src='https://www.socialnewsdaily.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202021.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'39845494',post:'89958',tz:'-4',srv:'www.socialnewsdaily.com'} ]);
	_stq.push([ 'clickTrackerInit', '39845494', '89958' ]);
</script>
</body></html>
